Problem reading Data from Excel file

For questions and discussion related to reading in and working with data.
PeterF
Posts: 55
Joined: Thu Apr 12, 2012 2:03 pm

Problem reading Data from Excel file

Unread post by PeterF »

Dear Tom,

I usually read data for the German ifo-index, which is comparable to the ISM indices in the US, directly via the URL into RATS. That worked well in the past. But after the release of new data today, I got the problem, that the data is not read into RATS. Therefore, I downloaded the Excel file and tried to read the data from the stored file. With the DATA wizard I got the following code

Code: Select all

OPEN DATA "C:\Users\User\Downloads\gsk-d-202305.xlsx"
CALENDAR(M) 2005:1
DATA(FORMAT=XLSX,NOLABELS,ORG=COLUMNS,TOP=10,RIGHT=4) 2005:01 2023:05 CLIMAT ACTUAL EXPECTATIONS
Executing these lines lead to the same result. View - Series Window displays the names of the three series, but no data is loaded. What is going wrong? I have attached the Excel file.

Maybe this problem relates to the upgrade to version 10.00g. The German language has umlauts, which I used also in the editor of RATS within strings for Graphs und Reports. Now, the editor shows strange characters where the is an umlaut in the program files. However, in reports and graphs the strings are correct. Also this Excel-Sheet contains strings with umlauts.

Best regards
PeterF
Attachments
gsk-d-202305.xlsx
(87.53 KiB) Downloaded 852 times
TomDoan
Posts: 7564
Joined: Wed Nov 01, 2006 4:36 pm

Re: Problem reading Data from Excel file

Unread post by TomDoan »

Add dateformat="mm/yyyy" as an option. Did their date format change from previous releases?
PeterF
Posts: 55
Joined: Thu Apr 12, 2012 2:03 pm

Re: Problem reading Data from Excel file

Unread post by PeterF »

Thank you Tom, that works.

In my original file I had dateformat="m/y" as an optin included. I don't know if they made a change in the date format as I read the data directly via an URL from the website, which is more convenient. As the start date is fixed, also using the option left=2 leads to getting the data into the series correctly.

Again thank you for the quick reply.

Best regards
PeterF
Post Reply