bootstrap Panel Var

Questions related to panel (pooled cross-section time series) data.

bootstrap Panel Var

Unread postby tyzellar » Wed May 18, 2022 1:28 pm

Hello everyone,
I am trying to use the bootstrapping procedure for the panel var model that I have but I receive this message when I run the code "## SR10. Missing Values And/Or SMPL Options Leave No Usable Data Points
The Error Occurred At Location 14723, Line 85 of loop/block" Could someone tell me how to debug this problem?

I also attached the dataset and the code file.
Thank you in advance.
I would appreciate any help.

Taulant Yzellari
Last edited by tyzellar on Mon May 23, 2022 2:49 pm, edited 1 time in total.
tyzellar
 
Posts: 11
Joined: Tue May 17, 2022 7:32 am

Re: bootstrap Panel Var

Unread postby TomDoan » Thu May 19, 2022 8:25 am

Your STARTE value is wrong for the data:

compute starte=1976:3

You're doing 4 lags on a VAR on differences with raw data starting at 1975:3 so you're losing five data points not four. That means that the earliest date for the simulations is 1976:4.
TomDoan
 
Posts: 7236
Joined: Wed Nov 01, 2006 5:36 pm

Re: bootstrap Panel Var

Unread postby tyzellar » Thu May 19, 2022 9:46 am

TomDoan wrote:Your STARTE value is wrong for the data:

compute starte=1976:3

You're doing 4 lags on a VAR on differences with raw data starting at 1975:3 so you're losing five data points not four. That means that the earliest date for the simulations is 1976:4.

Dear Tom,
Thank you very much. You gave me great help. It works perfectly now! :D
tyzellar
 
Posts: 11
Joined: Tue May 17, 2022 7:32 am


Return to Panel Data

Who is online

Users browsing this forum: No registered users and 0 guests